[strongSwan] bare minimum required kernel modules/version

Dimitrios Siganos dimitris at siganos.org
Thu Mar 18 16:59:04 CET 2010

No, the IPv6 related modules are not necessary but you have to have 
linux-2.6.29 or above.

Look at this thread for more details and workaround for earlier kernels:

I am using 2.6.28 and I worked around the problem by applying the 
disable-iaf-tunnels patch to strongswan.

Dimitris Siganos

Matthias Dahl wrote:
> Hi.
> I took over the maintainership of the strongswan ebuild on Gentoo and I am 
> currently in the process of polishing it as time permits.
> I'd like to add kernel config sanity checks to the ebuild, so a potential user 
> won't shoot his own feet. Looking around the wiki I found this:
>    http://wiki.strongswan.org/projects/strongswan/wiki/KernelModules
> Is this list the real bare minimum even if one only wants to use IPv4? I 
> recall there was some bug that prevented one from configuring w/o IPv6 on some 
> 2.6.28 kernel? I for one don't have "IP: policy routing" enabled (didn't know 
> it was "required") and strongswan still works just fine.
> That brings me to my next question: What is the suggested kernel version for 
> the 4.3.6 release? Currently we allow any 2.6 kernel but I guess that's just a 
> bad idea.
> Thanks for taking the time... and if you have any suggestions or critique for 
> the Gentoo ebuild, please let me know, so I can improve things.
> So long,
> matthias
> _______________________________________________
> Users mailing list
> Users at lists.strongswan.org
> https://lists.strongswan.org/mailman/listinfo/users

More information about the Users mailing list