<div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div>Hey guys,</div><div><br></div><div>I figured out my issue this morning. I needed to compile StrongSwan with¬†--enable-gcm. Now I can use AES256GCM. Pretty sweet.</div><div><br></div><div>When I try to use¬†diffieHellmanGroup = group19 on iOS though I get the following error message on the server.</div><div><br></div><div>Oct 15 15:17:03 de-fsn-x charon: 15[CFG]¬†selected proposal: IKE:AES_GCM_16_256/PRF_HMAC_SHA2_256/ECP_256</div><div>Oct 15 15:17:03 de-fsn-x charon: 15[IKE] DH group ECP_256 unacceptable, requesting ECP_256<br></div><div><br></div><div>Is that another plugin that I need to compile? Why is that DH group unacceptable?</div><div><br></div><div><br></div><div>Many Thanks,</div><div>Houman</div></div></div></div></div></div>