[strongSwan-dev] Linking Problem with xauth plugin on Android

Padhye, Anand (Anand) apadhye at avaya.com
Sat Apr 23 18:04:46 CEST 2011


I am trying compile and link on Android platform, the xauth plugin for pluto (..src/pluto/plugins/xauth..).
The libstrongswan-xauth.so is created, but during runtime, dlopen() fails for this library with the following error:

plugin 'xauth' failed to load : Cannot load library: reloc_library[1244]:  1931 cannot locate 'get_xauth_secret'...

It appears it's unable to load/link to symbols defined in pluto itself.
I tried "-rdynamic" option while compiling for android, but did not make any difference. Not sure if "rdynamic" is supported or Android.

I also tried dlopen(NULL, RTLD_LAZY) - with the intention of loading pluto's own symbols into the dynamic symbol table, but this dlopen call crashes and pluto exits. (Note: This works fine on regular Ubuntu linux - I tried just for the sake of comparison).

What' the way to get xauth plugin link properly on Android?

Thanks and regards,
Anand Padhye

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.strongswan.org/pipermail/dev/attachments/20110423/098dacaa/attachment.html>

More information about the Dev mailing list